Back to overview
Resolved
Infrastructure Upgrades
Jul 12, 2026 at 3:00am UTC
–
Jul 12, 2026 at 8:30am UTC
Affected services
American Legion
Sharon Memorial Hall
Worthington Noon Lions Club
Shaker Square
Public Website
Resolved
Jul 12, 2026 at 8:30am UTC
Maintenance ended
Affected services
Created
Jul 12, 2026 at 3:00am UTC
We're performing general infrastructure upgrades and sites will be down during this maintenance window.
Affected services